Pausing In OpenAL

F3ff2088fe22d64396b949f149628107
0
SpreeTree 101 Jan 26, 2004 at 20:34

Hi all

This seemed like the best plave to put a question about OpenAL, if not, let me know, or just move it ;)

According to the OpenAL docs, when you pause a source, the stste changes to Paused, and then you call alSourcePlay(_sourceID) to resume the source. Well, I cant get this to work. If I write:

alSourcePause(soundSource[_sourceID].source);
CCOPENAL_ERROR_CHECK_NO_RETURN("Pausing source :");
alSourcePlay(soundSource[_sourceID].source);

(where soundSource[_sourceID].source is the ID generated by OpenAL), the sample stops as it should, no errors are generated, and the state gets set to Paused. But then when I call the alSourcePlay function, the source plays, but from the start of the sample, not from where I paused it.

These two lines are called one after the other, so nothing else if resenting the buffer, just wondered if anyone had any ideas?

Cheers

Spree

6 Replies

Please log in or register to post a reply.

F7a4a748ecf664f189bb704a660b3573
0
anubis 101 Jan 26, 2004 at 22:14

i have no experience with openal so i can only direct you to the wonderful openal tuts here on devmaster. as there really is no place for sound related questions i will leave the post here :D

F3ff2088fe22d64396b949f149628107
0
SpreeTree 101 Jan 26, 2004 at 23:34

Yeah I’ve looked at the tutorials, but they dont really go into the problem. But thanks anyway :)

Spree

F7a4a748ecf664f189bb704a660b3573
0
anubis 101 Jan 27, 2004 at 09:10

np, i hope somebody else around here can help you

Fdbdc4176840d77fe6a8deca457595ab
0
dk 158 Jan 27, 2004 at 21:33

That’s a good question. Unfortunately, I’m not knowledgable with OpenAL either. The main guy is Jesse, the author of the tutorials. I hope he reads your post and answers your question.

F3ff2088fe22d64396b949f149628107
0
SpreeTree 101 Jan 27, 2004 at 22:07

Ah well, problem solved. Seems its a bug within the new openAL dll’s. alSourcePlay doesnt actually work in the way its meant too. Ive flagged it up on the dev mailing lists, just have to wait now… and I hate waiting ;)

Spree

Fdbdc4176840d77fe6a8deca457595ab
0
dk 158 Jan 28, 2004 at 06:17

Since a “Sound and Music Programming” forum has been created, I’ve moved all related questions to the new forum.