AUXillary Functions

40da7e74fdca33768b6714646853b3f5
0
TheLionKing 101 Aug 25, 2003 at 03:22

Hi,

I am using NeHe’s base code and when I creat an object … like Sphere with auxSolidSphere() it shows up but when I switch from Window to Fullscreen or Fullscreen to Window mode it doesn’t show up.

Can any one help me out :( ?

12 Replies

Please log in or register to post a reply.

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 25, 2003 at 12:27

well.. the first suggestion is: don’t use aux funcs.. they are depreciated, and buggy in some implementations, nobody really knows what they do..

or so i think.. nehe has something about quadriliars or how ever spelled.. cylinders, disks, spheres, etc. all with glu, without glaux.. i’ll suggest to look into these..

second: can you see the sphere as long as you don’t switch between windowed and fullscreen?

0684f9d33f52fa189aad7ac9e8c87510
0
baldurk 101 Aug 25, 2003 at 18:37

quadrics :).

Also, if you alt+tab away and back. Is it there?

40da7e74fdca33768b6714646853b3f5
0
TheLionKing 101 Aug 26, 2003 at 02:59

No … I cant see the sphere when switching.

When pressing ALT + TAB and come back … its there.

How do you draw a sphere if not using aux functions :wtf:

F7a4a748ecf664f189bb704a660b3573
0
anubis 101 Aug 26, 2003 at 06:14

google for tesselation…

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 26, 2003 at 07:10

i said yet, quadrics.

read up the Nehe Tutorials, they show howtodo it.

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 26, 2003 at 07:11

okay…. baldurk said it.. i spelled it wrong :D

40da7e74fdca33768b6714646853b3f5
0
TheLionKing 101 Aug 26, 2003 at 08:23

I know how to make Quads … just want to know that these sort of things when you use auxillary functions or not :huh: ?

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 26, 2003 at 08:47

hm? i don’t understand the question.

use the quadrics to do spheres and such, don’t use aux. thats what i said/wanted to say.

or code your own sphere-routine.

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 26, 2003 at 08:48
40da7e74fdca33768b6714646853b3f5
0
TheLionKing 101 Aug 26, 2003 at 09:56

Well … thanks :nod: I never got this much far in the nehes tutorials :blush: !

You gave me a cooked meal to eat ;) .

By the way … this problem happens with someone else or not with AUX Functions?

6ad5f8c742f1e8ec61000e2b0900fc76
0
davepermen 101 Aug 26, 2003 at 10:24

well, auxfuncs are known to be.. untested (we call this buggy normally:D), so you can never be sure when using them.

if such a thing does happen for stuff like textures, that get white on switching modes, then its merely a forgotten re-initialisation of data (wich could be the fault of the auxfunc in your case)

40da7e74fdca33768b6714646853b3f5
0
TheLionKing 101 Aug 27, 2003 at 03:00

Thanks … got the picture :rolleyes: !