alut.lib

B879c1afbb1589ef158a31193b6af401
0
yasin 101 Mar 06, 2007 at 14:05

Hi, while compiling a prog. i am getting eroor..cannot open file “alut.lib”
Where can i get this library file…i hav installed Openal SDK 1.1 (ver 3.3).
It doesn’t have this library file..Can any one tell me where can i get all these files

4 Replies

Please log in or register to post a reply.

C24eb7e6aaefba78b94c831ddc7b4d0b
0
donBerto 101 Mar 06, 2007 at 15:31
  1. Using my favorite search engine, I got these results
  2. I then found this link: http://www.ogre3d.org/wiki/index.php/OpenAL#Compiling
  3. Is this related?
B879c1afbb1589ef158a31193b6af401
0
yasin 101 Mar 08, 2007 at 10:37

hi thanx for the link…but i am not getting wot i need…i need alut.lib…but the link is not able to provide the proper downloadable.

F3ff2088fe22d64396b949f149628107
0
SpreeTree 101 Mar 09, 2007 at 08:32

As of 1.1, alut was depreciated. Not 100% sure if they totoally dropped the library (it’s been a while since I worked with OpenAL now :( ), but you should try too steer clear of alut if you want to progress with OpenAL.

067cb9c7f98462ac5efcb25ea571f21b
0
MuggenHor 101 Mar 18, 2007 at 23:50

@SpreeTree

As of 1.1, alut was depreciated. Not 100% sure if they totoally dropped the library (it’s been a while since I worked with OpenAL now :( ), but you should try too steer clear of alut if you want to progress with OpenAL.

Well some parts of alut are simply merged into the main OpenAL library.
So just make sure you use the 1.1 header files and then link against the 1.1 library files:
For windows you can use these to link against: http://developer.creative.com/articles/article.asp?cat=1&sbcat=31&top=38&aid=45
On GNU/Linux systems just make sure to have libopenal-dev installed.